# Earthscope hosted datasets mirror

**URL:** <https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411>\
**Category:** Site Feedback\
**Created:** [April 20, 2026, 4:18pm UTC](https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411 "2026-04-20T16:18:53Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![SolarEarth](https://yyz1.discourse-cdn.com/flex047/user_avatar/forum.generic-mapping-tools.org/solarearth/32/5195_2.png) [@SolarEarth](https://forum.generic-mapping-tools.org/u/SolarEarth)\
**Post date:** [April 20, 2026, 4:18pm UTC](https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411/1 "2026-04-20T16:18:53Z")

</div>

As part of the migration of GMT services from the University of Hawaii, a new dataset and gmt software server has been stood up on an EarthScope managed AWS S3 bucket and served via a temporary, prototype URL,[https://d3ei3ebu1iflov.cloudfront.net/gmt-data/data/](https://d3ei3ebu1iflov.cloudfront.net/gmt-data/data/)

The URL can be set in the GMT\_DATA\_SERVER variable.

Please check it out.

Static datasets input data for the tests can similarly be found at [GMT Datasets](https://d3ei3ebu1iflov.cloudfront.net/gmt-data/static/) and [GMT Datasets](https://d3ei3ebu1iflov.cloudfront.net/gmt-data/test/)

---

<div class="post-metadata">

**Author:** ![Andreas](https://avatars.discourse-cdn.com/v4/letter/a/ee7513/32.png) [@Andreas](https://forum.generic-mapping-tools.org/u/Andreas)\
**Post date:** [April 20, 2026, 8:27pm UTC](https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411/2 "2026-04-20T20:27:22Z")

</div>

Can you give a command example?

I tried

```auto
$ gmt grdcut -RNO --GMT_DATA_SERVER='https://d3ei3ebu1iflov.cloudfront.net/gmt-data/data/' @earth_age_05m -Gtrash.nc
gmt [NOTICE]: Downloading dcw-countries.txt for the first time - be patient
gmt [ERROR]: Libcurl Error: HTTP response code said error
gmt [ERROR]: Probably means dcw-countries does not exist on the remote server
gmt [ERROR]: Unable to obtain remote file dcw-countries.txt
gmt [WARNING]: gmt_get_dataset_tiles: No earth_age_05m_g tiles available for your region.
grdcut [NOTICE]: Downloading dcw-countries.txt for the first time - be patient
grdcut [ERROR]: Libcurl Error: HTTP response code said error
grdcut [ERROR]: Probably means dcw-countries does not exist on the remote server
grdcut [ERROR]: Unable to obtain remote file dcw-countries.txt
grdcut [ERROR]: Grid y range <= 0.0
grdcut (gmtapi_init_grdheader): Please select compatible -R and -I values
grdcut [ERROR]: Requested subset is entirely below or above the current grid region

```

```auto
$ gmt grdcut -RNO --GMT_DATA_SERVER='d3ei3ebu1iflov.cloudfront.net/gmt-data/data/' @earth_age_05m -Gtrash.nc
gmt [NOTICE]: Downloading dcw-countries.txt for the first time - be patient
gmt [ERROR]: Libcurl Error: HTTP response code said error
gmt [ERROR]: Probably means dcw-countries does not exist on the remote server
gmt [ERROR]: Unable to obtain remote file dcw-countries.txt
gmt [WARNING]: gmt_get_dataset_tiles: No earth_age_05m_g tiles available for your region.
grdcut [NOTICE]: Downloading dcw-countries.txt for the first time - be patient
grdcut [ERROR]: Libcurl Error: HTTP response code said error
grdcut [ERROR]: Probably means dcw-countries does not exist on the remote server
grdcut [ERROR]: Unable to obtain remote file dcw-countries.txt
grdcut [ERROR]: Grid y range <= 0.0
grdcut (gmtapi_init_grdheader): Please select compatible -R and -I values
grdcut [ERROR]: Requested subset is entirely below or above the current grid region

```

I see that the URL you gave is HTTPS; the other mirrors use HTTP. Does that make a difference?

**Edit** : nevermind, HTTPS works as well, [https://oceania.generic-mapping-tools.org/](https://oceania.generic-mapping-tools.org/).

---

<div class="post-metadata">

**Author:** ![seisman](https://yyz1.discourse-cdn.com/flex047/user_avatar/forum.generic-mapping-tools.org/seisman/32/4_2.png) [@seisman](https://forum.generic-mapping-tools.org/u/seisman)\
**Post date:** [April 22, 2026, 4:54pm UTC](https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411/3 "2026-04-22T16:54:32Z")

</div>

Your command also fails for me but works after removing the trailing slash, i.e., changing `/gmt-data/data/` to `/gmt-data/data`.

---

<div class="post-metadata">

**Author:** ![SolarEarth](https://yyz1.discourse-cdn.com/flex047/user_avatar/forum.generic-mapping-tools.org/solarearth/32/5195_2.png) [@SolarEarth](https://forum.generic-mapping-tools.org/u/SolarEarth)\
**Post date:** [April 22, 2026, 6:24pm UTC](https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411/4 "2026-04-22T18:24:55Z")

</div>

The problem is that the subdirectory path to the dataset was being simply appended to the data server URL causing an extra ‘/’ to be added. It seams many servers ignore multiple '//'s but the AWS system does not.

With the help of Claude, I was able to add a function to the AWS CloudFront system to collapse multiple / characters into one (eg. gmt-data/data//server → gmt-data/data/server) which resolved the problem of the trailing slash in my trial.

---

<div class="post-metadata">

**Author:** ![Joaquim](https://yyz1.discourse-cdn.com/flex047/user_avatar/forum.generic-mapping-tools.org/joaquim/32/16_2.png) [@Joaquim](https://forum.generic-mapping-tools.org/u/Joaquim)\
**Post date:** [April 22, 2026, 8:45pm UTC](https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411/5 "2026-04-22T20:45:53Z")

</div>

Please, have a look at this as well

> <https://github.com/GenericMappingTools/gmt/issues/8927>
>
> With the black down of the Hawaii server (Forum is down) many CI tests fail, all… GMT.jl tests fail too. 
> Tried to
> \`set (GMT\_DATA\_SERVER china)\`
> but no luck, and local runs fail with
> 
> \`\`\`
> C:\\v\>grdinfo @earth\_relief\_01d\_p
> unknown \[ERROR\]: Bad record counter in file C:/Users/j/.gmt/gmt\_data\_server.txt
> unknown \[ERROR\]: Deleting C:/Users/j/.gmt/gmt\_data\_server.txt so it can get regenerated - please try again
> grdinfo \[ERROR\]: Unable to open file C:/Users/j/.gmt/gmt\_data\_server.txt
> grdinfo \[ERROR\]: Remote download is currently deactivated
> grdinfo \[ERROR\]: Unable to obtain remote file @earth\_relief\_01d\_p
> grdinfo \[ERROR\]: Must specify one or more input files
> \`\`\`

---

<div class="post-metadata">

**Author:** ![Andreas](https://avatars.discourse-cdn.com/v4/letter/a/ee7513/32.png) [@Andreas](https://forum.generic-mapping-tools.org/u/Andreas)\
**Post date:** [April 23, 2026, 12:54pm UTC](https://forum.generic-mapping-tools.org/t/earthscope-hosted-datasets-mirror/6411/6 "2026-04-23T12:54:24Z")

</div>

Great, now both of my original commands work.
