Backtracker segmentation fault

I’m encountering some strange behavior with gmt backtracker. I have a set of locations with ages I am trying to backtrack but I keep getting this ERROR: Caught signal number 11 (Segmentation fault: 11) at
0 libsystem_platform.dylib 0x000000018e150864 _platform_strlen + 4
1 ??? 0x0000000000000100 0x0 + 256
Stack backtrace:
0 libgmt.6.4.0.dylib 0x000000010344e6f4 sig_handler_unix + 264
1 libsystem_platform.dylib 0x000000018e1534a4 _sigtramp + 56
2 libsystem_c.dylib 0x000000018dfff6a0 __vfprintf + 4544
3 libsystem_c.dylib 0x000000018e02d764 _vsnprintf + 224
4 libgmt.6.4.0.dylib 0x00000001032e2690 GMT_Report + 780
5 0x0000000106abd7ec GMT_backtracker + 1536
6 libgmt.6.4.0.dylib 0x00000001032eb14c GMT_Call_Module + 1332
7 gmt 0x000000010296dd50 main + 948
8 dyld 0x0000000102b4108c start + 520

The strange part is if I pip the coordinates / ages in, backtracker works fine e.g.

echo -37.8153 -31.4005 84.2 | gmt backtracker -ESAM-AFR > RGR_hot_spotted.xy

works, but when I try using a file, e.g.

gmt backtracker $RGR_locations -ESAM-AFR > RGR_hot_spotted.xy

I get the error. I’ve tried multiple different $RGR_location files to see if that was the issue but to no avail. The really strange thing is that it also occurs when I try and add a -M0.5 to backtracker. Even when I pip in coordinates / age like:

echo -37.8153 -31.4005 84.2 | gmt backtracker -ESAM-AFR -M0.5 > RGR_hot_spotted.xy

I will get the same segmentation fault error. Any ideas? Eventually I want to take a dataset of points with ages and backtrack them but using the -M0.5 scaling factor. Many thanks

  • Peter

Hi Peter, I cannot reproduce it. I am running 6.4 as you for this test (macOS bundle). Unless there is some junk in your $RGR_locations file of course.

Works fine:
echo -37.8153 -31.4005 84.2 | gmt backtracker -ESAM-AFR > RGR_hot_spotted.xy

echo -37.8153 -31.4005 84.2 > t.txt
gmt backtracker -ESAM-AFR t.txt > RGR_hot_spotted.xy

Hi Paul, yes I’m also running 6.4 on macOS. I can’t figure out what might be wrong with my input files since it occurs on all that I try, including running the script above where the lat/lon/age is echoed into a .txt and then ran through backtracker. I wonder if something is getting confused on the back end of my computer?

Only backtracker or does psxy also give the same response? Since all the table tools in GMT share the same internal i/o it is hard to understand what is happening. Food for thought:

  1. More than one GMT installation?
  2. does od -c $RGR_locations give odd non-text output at the ends or anywhere.


I did indeed have an old GMT5.4 installed, but deleting that didn’t help. Anyways, I got a new work computer last week and did a fresh homebrew install of GMT6.5 on there. Unfortunately it’s not working here either, though for a different reason. When I run

gmt backtracker $RGR_dredges -ESAM-AFR -V > ${tempfiles}RGR_backtracked.xy

I get

backtracker [ERROR]: Unable to find GPLATES_ROTATIONS file : /opt/homebrew/Cellar/gmt/6.5.0/share/gmt/Muller2019-Young2019-Cao2020_CombinedRotations.rot.rot

When I go to that file directory, indeed the rotation files are not there, but one folder deeper in ‘/spotter’, so how do I get backtracker to look there instead? Many thanks