Cannot open / start GMT in MacOS

GMT will not open on iMac using MacOS Big Sur. Clicking on the GMT icon does nothing, as though it crashes immediately. There was a pop-up about Mac blocking software with invalid certificates. Any advice?

Thank you! - Andy

BTW, MacOS “Security & Privacy” does not show the override option. Right now, I cannot get to the error message either.

can you open a terminal and type

gmt --version


Apple is overparanoid on this, but you just have to be persistent. You may have to click on a few extra buttons.

Thanks; I removed GMT, found a “GMT” folder from 2017 in my Applications, and removed that too.

Rebooted in “Safe mode”, and logged in in “Safe mode”. That usually cleans out leftover issues and problems.

Downloaded the MacOS x86 version again, and installed. Got the pop-up of refusal from Apple, went to “Security and Privacy”, clicked on “Open anyway”. Nothing happened. That pop-up only shows up on the first opening, then not again.

Typed in “get --version” and got:

andrewlazarewicz@FantasyReef ~ % gmt

zsh: command not found: gmt

andrewlazarewicz@FantasyReef ~ % which gmt

gmt not found

Used terminal to get into “/Applications/”, dug down a bit and got:

Last login: Mon Aug 23 16:41:10 on ttys000
/Applications/ ; exit;
andrewlazarewicz@FantasyReef ~ % /Applications/ ; exit;

GMT - The Generic Mapping Tools, Version 6.2.0 [64-bit] [MP] [8 cores]
(c) 1991-2021 The GMT Team (

Yes, I agree that Apple is overly paranoid, and usually “Open anyway” does work. It seems as though Apple blocked GMT from my PATH. I’ll rummage around and see if I can figure it out. But this may be a local problem, as other users don’t seem to complain much about this.

Thank you! - Andy

Oops, too much cut and pasting; error in my note, it should be:

andrewlazarewicz@FantasyReef ~ % gmt – version
zsh: command not found: gmt

The GMT splash screen gives these instructions for using GMT outside the terminal opened by the app. I expect that setting these in a .bashrc for bash or .zshrc for zsh would be a simpler solution than figuring out the gatekeeper solution. Then you would be able to use your regular terminal.

There may be a couple features designed for bash that do not work for zsh (e.g., gmt command -?, but user feedback suggests that most GMT commands work fine in the new default shell.

Note 1: If you want to use GMT outside of this terminal or in scripts, then follow these steps:
        a) export GMTHOME=/Applications/
        b) add $GMTHOME/bin to your path
        c) export PROJ_LIB=$GMTHOME/share/proj
        d) export GS_LIB=$GMTHOME/share/ghostscript/9.53.3/Resource/Init
        e) export MAGICK_CONFIGURE_PATH=$GMTHOME/lib/GraphicsMagick/config
Note 2: GMT may use Ghostscript, GraphicsMagick, FFmpeg, and GDAL executables; see
        /Applications/ for details.