Cannot read GSHHG files with GMT6 on Cygwin


I just installed GMT6 on Cygwin.

Everything works fine except accessing GSHHG files.

When I run for example pscoast, I get the foillowing errors:
gshhg_version: cannot open file “/home/doublon/gmt/gshhg-gmt-2.3.7/” (-101).
pscoast [ERROR]: 1. GSHHG: Found /home/doublon/gmt/gshhg-gmt-2.3.7/ but cannot read it due to wrong permissions
pscoast [ERROR]: GSHHG version 2.2.0 or newer is needed to use coastlines with GMT.
Get and install GSHHG from
pscoast [ERROR]: Could not find file [GSHHG full resolution shorelines]
pscoast [ERROR]: No GSHHG databases available - must abort

However gshhg-gmt-2.3.7 is installed, with full access permissions.


What do you mean with this? Did you build GMT yourself in Cygwin or used the Windows installer? If later, you should had let it install where proposed (c:\programs\gmt6)

I installed it building GMT myself from the source, following instructions in

It smells a netCDF error. That message is issued when

status = nc_open(filename, NC_NOWRITE, &ncid);


Cygwin builds are not tested. Why don’t you just use the Windows binaries.

I was used to install previous versions on Cygwin from sources.
I do not know how to use Windows binaries; I will try and find out to follow your suggestion.

By the way, recently my GMT5 (not GMT6) had suddenly the same problem with GSHHG, with no apparent reason. This is why I tried to install GMT6.

Thank you.

Looks like some update screwed the netCDF or HDF5 libs