Can't open PostScript Files with GMT6.3.0

I had no idea there was a forum! Hopefully I explain my issue correctly.

Im new to this and am trying to learn several programs at once. I used MB Systems to process some bathymetry and now am trying to generate a GMT map of gridded data. BTW I contacted MB Systems about the following problem first, they told me its probably a GMT question.

as far as I understand it this is the workflow: MB System has a macro that generates a command (.cmd) that creates a PostScript file that GMT then reads and generates a map. After I run the command it generates a PostScript and then Preview (I’m on a Mac) stops it from opening. It says that the Postscript file can’t be converted to a PDF. Im not sure where I’m going wrong, I’ve tried generating new files and doing the process again several times. Im using bash and GMT 6.3.0 and the latest update of MB Systems, let me know if you think I can change something that will help me open these maps. Thank you!!

Here’s the script I wrote:

mbm_plot -F59 -I 0021_20210822_141804_Sikuliaq.mb59 -G1 -C -N -V -Obathcont

It then generated this command with the following instructions:

Execute <bathcont.cmd> to generate Postscript plot <>.

When I run that command, it generates a new .ps file and Preview opens up to open the PDF and I get this message:
PostScript Conversion Error
The PostScript file “” could not be converted to a PDF file.

this website won’t let me attach any of my files and the files won’t allow me to open them with a text editor. Thanks again!


The MB perl script does stuff and calls GMT and makes a plot in the form of a PostScript file. If that plot cannot be opened in Preview or converted via psconvert to PDF or JPG etc then there is something wrong with the PS file. You could zip it up and post it here so we can have a look,

Note that GMT does not read a PostSCript file really, it produces PostScript which we then can convert to other things. AL the MB scripts are using GMT classic mode which only produce PostSCript.

Thanks for clarifying! I would guess I’m in classic mode, do you know how to change that? The file is too large to attach so here’s a google drive link for the files. Thanks for your help!


Google Drive:

The postscript file is missing the part from mbcontour so I assumed that command did not complete. Hence the rest of the PS file is of no use and cannot be viewed etc (kind of like a program missing the fist few hundred lines will very likely not compile).

Suggest you run that cmd script this way

bash -xv bathcont.cmd

and pay attention to what happens when mbcontour is called.

So I ran the command again and both mbcontour and mbswath both came back with errors saying the command could not be found. I reinstalled some MBSystems libraries and the ran script the way you suggested and it worked! Thanks again for your help!


Great, yes the shared library needs to be accessible to GMT.

1 Like