Decrypting error message sphinterpolate [ERROR]: Error in INTRC0: I = 143, J = 353, IER = -3

Hi all,

Trying to do an sphinterpolate, which returns the following error:
sphinterpolate [ERROR]: Error in INTRC0: I = 143, J = 353, IER = -3
How can I make sense of this?

Using GMT 6 in Windows 10 and today is the first day I give it a try. Managed succesfully to do a blockmean with GMT.


If you land here because you got a similar error. I didn’t get a definitive answer, but think the problem was too few points.

Sorry that we didn’t get back to you on time before. Did you try running with debug mode on (e.g. sphinterpolate ... -Vd)? It might print other useful information that is less cryptic.

Thank you Wei Ji for the suggestion.

The grid I am using is only for the South Atlantic. Using a smaller region instead of the whole globe solved the error.
The debug information adds “(gmt_ssrfpack_grid) tried to free unallocated memory”. I would interpret this as too few points provided and too many to get through interpolation.