ERROR: Caught signal number 11 (Segmentation fault) at /lib/x86_64-linux-gnu/libc.so.6(+0xb1426)[0x7f576c0c1426] [0x4]

Hi all,

I am trying to plot a set of tangential component of receiver function, RFs, data on GMT Version 5.4.3 (r19528), but I got the lines of error message below.

Meanwhile, I had previously used the same script to plot for radial and tangential components of the same station, and it produced the plots.

The scripts to plot the radial component still works well and produce the plots. But, as I ran the scripts again on the tangential components of the RFs again for the same station and other stations, it brought out the error message.

Can you please advise? Thanks.

ERROR: Caught signal number 11 (Segmentation fault) at
/lib/x86_64-linux-gnu/libc.so.6(+0xb1426)[0x7f576c0c1426]
[0x4]
Stack backtrace:
/usr/lib/x86_64-linux-gnu/libgmt.so.5(sig_handler+0x2b1)[0x7f576c64bbf1]
/lib/x86_64-linux-gnu/libpthread.so.0(+0x12980)[0x7f576c413980]
/lib/x86_64-linux-gnu/libc.so.6(+0xb1426)[0x7f576c0c1426]
/lib/x86_64-linux-gnu/libc.so.6(+0x5ab45)[0x7f576c06ab45]
/lib/x86_64-linux-gnu/libc.so.6(_IO_vfprintf+0x192a)[0x7f576c06cdba]
/lib/x86_64-linux-gnu/libc.so.6(__vsnprintf_chk+0xa9)[0x7f576c141ff9]
/usr/lib/x86_64-linux-gnu/libgmt.so.5(GMT_Report+0x1a2)[0x7f576c64fba2]
/usr/lib/x86_64-linux-gnu/gmt/plugins/supplements.so(GMT_pssac+0x2e6b)[0x7f5757570dcb]
/usr/lib/x86_64-linux-gnu/libgmt.so.5(GMT_Call_Module+0xc6)[0x7f576c657296]
gmt(main+0x8ae)[0x5588496c061e]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xe7)[0x7f576c031bf7]
gmt(_start+0x2a)[0x5588496c089a]

You’re using a very old version (GMT Version 5.4.3). You should try upgrading first, to see if the problem persists.

Thank you for the response @Andreas . I have tried running the script on GMT 6.1 and still encountered the same error message.

Please, find below the commands in the script for GMT 5.4

cd SAC/for_receiver
gmt psbasemap -R-5/30/0.035/0.085 -JX2i/3i -B5f1:“Time (s)”:/0.005f0.001:“p (s/km)”:WenS -K -P -X2i > rf_zi.ps
gmt pssac *.zi -R -JX -B -W0.5p -M0.3 -Eu4 -K -P -O >>rf_zi.ps

ps2pdf rf_zi.ps
evince rf_zi.pdf

I have also adapted the script to GMT 6.1 format and ran on same, but I still got the same error message.

I do hope I can find helpful suggestions.
Thanks.

'Yomi Gaius

Yomi,

We need more than that. We need a little WORKING example that reproduces the error.Can you isolate one file where the crash occurs and make it available to us?