Error using gravfft


I am trying to calculate a bouguer anomaly using a bathymetric data, however, it is showing this error:

gravfft [ERROR]: Input grid Bogdanov_FZ_100m_LL.1min.grd contain NaNs, cannot do FFT!
ERROR: Caught signal number 11 (Segmentation fault: 11) at
0 0x0000000112452d0a GMT_gravfft + 7042
1 ??? 0x0000000000000028 0x0 + 40
Stack backtrace:
0 libgmt.6.3.0.dylib 0x0000000109fd1fd6 sig_handler_unix + 210
1 libsystem_platform.dylib 0x00007fff20376d7d _sigtramp + 29
2 ??? 0x0000000000000000 0x0 + 0
3 libgmt.6.3.0.dylib 0x0000000109f174ee GMT_Call_Module + 1947
4 gmt 0x0000000109ee35fc main + 1727
5 libdyld.dylib 0x00007fff2034cf3d start + 1
6 ??? 0x0000000000000006 0x0 + 6

I tried to find a solution but I did have success. Someone know what can be it?

Guilherme de Melo

You cannot take an FFT of an incomplete dataset (your NaNs).
Either fill in the gaps or use a spatial method, e.g., grdgravmag3d.

And it shouldn’t crash but quite a lot of work went into the FFT machinery after 6.3.0 so probably the crash is solved too.


My GMT is the 6.3.0 version. I filled the gap of multibeam data on .grd file with global SRTM15+ data and it worked well. Thank you for information. :slight_smile: