Explicitly specify path to ghostscript

OS: Rocky Linux 8.5
GMT: 5.3.0_r16358 hand compiled (I know, I know…)

As Rocky Linux 8.5 ships with ghostscript 9.27, I believe I have run into this bug. As 9.27 is the newest available in the Red Hat world, I’ve manually built and installed (in a separate location) ghostscript 9.55.0. This solves my bug, but gives compatibility problems with the other parts of ghostscript provided by the system, specifically ghostview.

I’ve deduced that GMT uses the $PATH variable when it looks for the ghostscript binary (gs). Is there a way to specify that on the command line, or in a config file?

Your only other option is to use the psconvert -G option. But 9.27, seriously? I would complain they are shipping a known broken version from years past.