Filter1d warnings

I’m estimating the running mean using filter1d with a filter width of 6 hours with start and end time using -T option to get evenly spaced data every 6 hours. I make sure that the time unit of my time series in an hour, designated as h.

gmt filter1d -f0T -Fb6 $input_file -N0 --TIME_UNIT=h -E -T$start/$end/6 -V > output

However, I get a warning as below?

filter1d [WARNING]: TIME_UNIT is invalid. Default assumed.
filter1d [WARNING]: Choose one only from y o d h m s
filter1d [WARNING]: Corresponding to year month day hour minute second
filter1d [WARNING]: Note year and month are simply defined (365.2425 days and 1/12 of a year)

I believe the command is ok and I do not understand where the warnings are coming from?


I cannot reproduce that here. I tried;

gmt math -T2020-01-01T/2020-01-02T/60 0 1 NRAND = t.txt
gmt filter1d t.txt -f0T -Fb6 -N0 --TIME_UNIT=h -E -T2020-01-01T/2020-01-02T/6 > a.txt

Worked fine for me. It is always possible there was a bug in an earlier version but I dont recall something like this. I am running master.