GMT 6.2.0 released

The GMT team is pleased to finally roll out the early summer 6.2.0 release via GitHub Releases. Apart from numerous bug fixes, there is a new module (gmtbinstats), many new options to existing modules, and introduction of the GMT_THEME setting which for modern mode will default to modern. A key feature of the new theme is automatic size adjustment of fonts and pen-thicknesses depending on the size of the illustration, plus a more modern feel to basemap frame settings. GMT classic mode remains in classic mode but have access to the modern theme as well. For a complete listing of changes, see the changelog.
We hope you will be pleased with the latest release. If you find any bugs please report issues on GitHub or if you are not sure you can post general questions on our Q & A Forum.

4 Likes

Great!! Congratulations to the team!!

I think the correct link in changelog is:

https://docs.generic-mapping-tools.org/6.2.0/changes.html

Thanks, and fixed.

Well done !
But I’ve just downloaded 6.2.0 x86-64 dmg version and tried to compile a file that worked well with 6.1.1 and then compilation failed to load psconvert. The script output says :

 psconvert [ERROR]: System call [gs -q -dNOSAFER -dNOPAUSE -dBATCH -sDEVICE=bbox -DPSL_no_pagefill -dMaxBitmap=2147483647 -dUseFastColor=true '/Users/clangloi/.gmt/sessions/gmt_session.1433/gmt_0.ps-' 2> '/Users/clangloi/.gmt/sessions/gmt_session.1433/psconvert_1447c.bb'] returned error 256.
psconvert [ERROR]: System call [gs -q -dNOSAFER -dNOPAUSE -dBATCH -sDEVICE=bbox -DPSL_no_pagefill -dMaxBitmap=2147483647 -dUseFastColor=true '/Users/clangloi/.gmt/sessions/gmt_session.1433/gmt_0.ps-' 2> '/Users/clangloi/.gmt/sessions/gmt_session.1433/psconvert_1453c.bb'] returned error 256.
end [ERROR]: Failed to call psconvert
end [ERROR]: gmtinit_process_figures returned error 79 

When returning back to GMT6.1.1, the map is done as expected. I add the script below.
GMT6_Canaries_Madere.txt (2.9 KB)

You need to follow the instructions at the end of the GMT splash screen. For the psconvert issue, you need to set the following environment variable:

export GS_LIB=${GMTHOME}/share/ghostscript/9.53.3/Resource/Init

Oups ! Yes, I’ve missed this line of instruction. I’ve set all others paths except this one. It works now. Thanks for the help.

First, congratulations for the 6.2 release!

Minor detail: When I follow the link to the change log I only get a Page not found error message. Both in @pwessel’s post as well as with @Esteban82’s link.

Maybe this one is the correct one?

https://docs.generic-mapping-tools.org/6.2/changes.html

You are right. Not sure what happened but that was Paul’s original link that he later changed after my comment.

The correct link is https://docs.generic-mapping-tools.org/6.2/changes.html

I just edit the links of @pwessel and @Esteban82’s comments to avoid further confusion.

1 Like