Gmt-6.4.0 install error on Centos 7

Hello all,

I am trying to build up and install gmt-6.4.0 on my Centos 7.

I installed the required dependencies but when try to built files as in the build manual by typing below command, I am having following error,

cmake --build .
ninja: error: loading ‘’: No such file or directory

I have install ninja by yum install ninja-build but when try to build the files in “gmt-6.4.0/build” directory I am having “ninja: error: loading ‘’: No such file or directory”

when type the “cmake --build . --target install” command, I am also having the same error “ninja: error: loading ‘’: No such file or directory”

Does anybody receive this kind of error before? Does anyone has any suggestion to solve this issue?

best wishes,

To build via Ninja you first need set set the generator: Here is why do before build:

cmake -G Ninja ..

Dear pwessel,

I did what you suggested before “cmake --build .” and tried “cmake --build .” again but I am having the same error.

In the mean time, when I try to install gmt with yum like “yum install gmt” it tries to install an older version gmt, is there a way to install newer version of gmt with yum in Centos?

Pinging @Andreas and @Esteban82 as Linux users who may know.

I use ubuntu, so I don’t know about yum.

Dear all,

I installed gmt-6.4.0 by conda, this was pretty smooth. I will test my basic maps now,

best wishes,