GMT 6.4.0: nearneighbor [ERROR]: Option -Nn: Requires GDAL 2.1 or later

I just installed GMT 6.4.0 on CentOS but when I try to run “gmt near neighbor tmp -N1…” I get the errror above about GDAL. How do I fix this?

Thank you,

Presumably you have a very old GDAL or none at all? Try this. When I do this it should the GDAL version:

gdal_translate --version
GDAL 3.6.4, released 2023/04/17 (debug build)

Hard to believe CentOS would have something < 2.1 so maybe there is no goal installed?

Argh! I’ve got GDAL 1.11.4. Mahalo Paul