Gmt [ERROR]: Shared GMT module not found: image

gmt image doesn’t seem to work. I found an old item on this by JL but it was closed on github without explanation. I’m trying to add a jp2 image to a map and get this:

gmt image m_3311754_sw_11_h_20160809_20161004.jp2
gmt [ERROR]: Shared GMT module not found: image

ERROR: No module named image was found. This could mean one of four cases:

  1. There actually is no such module; please check your spelling.
  2. You used a modern mode module name while running in GMT classic mode.
  3. Module exists in the GMT supplemental library, but the library could not be found.
  4. Module exists in a GMT custom library, but none was specified via GMT_CUSTOM_LIBS.
    Shared libraries must be in standard system paths or set via environmental parameter DYLD_LIBRARY_PATH

However, if I just execute
gmt image

I get all the help info. I just rebuilt gmt6 with the latest git update and this is the result. Haven’t tried gmt image before so don’t know if if ever worked.

I tried adding the new lib path to DYLD_LIBRARY_PATH and it didn’t have any effect.

Any advice much appreciated.

I am able to get grdimage to work with this, however.

All correct. There is no module called image in classic mode. The name is psimage. image is only in modern.