Gmtset -Ve

So far I used GMT4 and try out 6.3 for the very first time. And I am puzzled right from the beginning:
I use
gmtset -Ve
psxy -R0/1/0/1 -JX1 /dev/null > /tmp/
and get this output (which I do NOT want)
psxy [WARNING]: File /dev/null is empty!

Do I missinterpret the manpage of gmtset or is this a bug?

And another bug(?) in GMT6.3.0:
makecpt -Cpanoply -T1/10/2 -Qo -N
makecpt [WARNING]: panoply is a discrete CPT. You can stretch it (-T/) but not interpolate it (-T//).
makecpt [WARNING]: Selecting the given range and ignoring the increment setting.
1 4/14/216 1.5625 4/14/216 L
1.5625 32/80/255 2.125 32/80/255 L
2.125 65/150/255 2.6875 65/150/255 L
2.6875 109/193/255 3.25 109/193/255 L
3.25 134/217/255 3.8125 134/217/255 L
3.8125 156/238/255 4.375 156/238/255 L
4.375 175/245/255 4.9375 175/245/255 L
4.9375 206/255/255 5.5 206/255/255 L
5.5 255/254/71 6.0625 255/254/71 L
6.0625 255/235/0 6.625 255/235/0 L
6.625 255/196/0 7.1875 255/196/0 L
7.1875 255/144/0 7.75 255/144/0 L
7.75 255/72/0 8.3125 255/72/0 L
8.3125 red 8.875 red L
8.875 213/0/0 9.4375 213/0/0 L
9.4375 158/0/0 10 158/0/0 B

in GMT4.x I get correctly:
akecpt -Cpanoply -T1/10/2 -Qo -N
1 65/150/255 2 65/150/255
2 255/254/71 5 255/254/71
5 red 10 red

NOTE: The log scale is not necessary to produce the WARNING output.

Should have been

gmtset GMT_VERBOSE=e
psxy -R0/1/0/1 -JX1 /dev/null > /tmp/
psxy [WARNING]: File /dev/null is empty!

but it works from command line

psxy -R0/1/0/1 -JX1 /dev/null -Ve > /tmp/

you probably know already, but anyway: psxy has option -T which can be used if no input files is needed psxy — GMT 6.3.0 documentation or psxy — GMT 5.4.6_c5d65a4_2019.11.05 documentation or PSXY
your line would be
psxy -R0/1/0/1 -JX1 -T > /tmp/

Personally I still find psxy -T syntax very useful to explicitly set the projection and the map region or to switch between UTM and Mercator oblique, similar to what happens in GMT example 28.

Dear Joaquim, many thnks for your answers, But I am still not understanding everything:

I will try “psxy -Ve” tomorrow, but shouldn’t the setting of gmt.conf (VERBOSE = error) be used from psxy? gmtset -VE does set the gmt.conf correctly, but why does psxy not use ist?

Many thanks for mentinening the option -T, I wasn’t aware of it yet. -> tomorrow :slight_smile:

With respect to the

I would expect GMT4, without -T/ the output is (at least for log scales) not usefull.
What GMT4-makecpt did was very usefull. So I could reformulate my question:
How can I get this output with GMT6?

makecpt -Cpanoply -T1/10/2 -Qo -N
1 65/150/255 2 65/150/255
2 255/254/71 5 255/254/71
5 red 10 red

Not 100% sure of what I’m saying but I think you can’t. If I remember well (and GMT4 was > 10 year ago) it was decided that discrete palettes cannot be interpolated and previous behavior was a bug. But if you are looking at making discrete and log scale cpts, have a look at this test

I think there has been some regression. We should not police what people wants to do. I will check later this week.

The psxy -T is GMT 4 for sure.

Many thanks to both of you. Your comments help my (too long postponed) transition to GMT6 …
Kind regards,