Grdfilter domain

Hello, I have a problem using grdfilter. I have a bathymetry grid created by mbsystem with format nf=GMT netCDF format (32-bit float, COARDS, CF-1.5. The idea is to get the residual bathymetry applying a high pass filter but when I try to apply grdfilter with this command:
gmt grdfilter GridBaty.grd -Gresidual_baty.grd -Fm1+h -D4 -R -V

Appears this error:
grdfilter: Output grid domain incompatible with input grid domain

I think it refers to a space or time domain, my data are in space domain, so I don`t understand what is happening.
I changed the format with grdconvert to convert from .grd to .nc but the mistake is still.
Could someone help me to understand what happen?
Thanks a lot,
Cheers

You have -R without an argument, implying that the -R setting will be inherited from the history. What is the last -R setting that you prescribed and how does it compare to the region in GridBaty.grd?

Thanks for your answer.
According with the grdfilter man page:
-R [Default: Same as input.] for this reason I used only -R.
I have just applied -Rwest/east/south/north (with real values) but the error is the same:
grdfilter: Output grid domain incompatible with input grid domain :frowning:

Perhaps you can tell us what gmt grdinfo GridBaty.grd returns and what your -Rw/e/s/n was?

Sure :slight_smile:
That is the info from grdinfo:

GridBaty.grd: Title: Topography Grid
GridBaty.grd: Command: mbgrid
GridBaty.grd: Remark:
Projection: Geographic
Grid created by mbgrid
MB-system Version 5.5.2284
Run by on <diegore.local> at <Mon Jan 31 22:25:44 2022>
GridBaty.grd: Gridline node registration used [Geographic grid]
GridBaty.grd: Grid file format: nf = GMT netCDF format (32-bit float), COARDS, CF-1.5
GridBaty.grd: x_min: -94.995217813 x_max: -93.8113496295 x_inc: 0.000371817896842 name: Longitude n_columns: 3185
GridBaty.grd: y_min: 14.530781289 y_max: 15.3524852296 y_inc: 0.000361506353101 name: Latitude n_rows: 2274
GridBaty.grd: z_min: -4159.05419922 z_max: -248.255981445 name: Topography (m)
GridBaty.grd: scale_factor: 1 add_offset: 0
GridBaty.grd: format: netCDF-4 chunk_size: 133,134 shuffle: on deflation_level: 3

And what was your -Rw/e/s/n?

Ohh, sorry!
I used the same from the grdinfo:

-R-94.995217813/ -93.8113496295/ 14.530781289/ 15.3524852296

With such crazy increments and limits I suspect there is roundoff via -R. I usually use mbgrid with an increment in arc seconds for geographic data…

If you do not want to limit the region then do not give any -R setting. The message

-R [Default: Same as input.]

means you get the input region if you DO NOT use -R.

Ok, I understand now. It works.
Thanks a lot Paul,
Cheers