Grdtrack : -C option /spacing between cross tracks not taking effect

while running grdtrack with -C length /ds [/spacing ] option. The last option spacing which gives the spacing between individual tracks doesn’t seem to work.
No matter what spacing I give it erects cross profiles at all points given in the track.
like grdtrack -C500k/1 and grdtrack -C500k/1/10 gives the same result. Is the option not working or I am doing something wrong ???
I am using the latest gmt version 6.2.0rc2 built from the source through git clone.

Kindly let me know.

Sorry, Didn’t know that we have to use -A[r/R] option for the spacing between tracks to take effect when used in conjunction with -C or -E options.
Ran again using -Ar option and got the expected Results.

Leaving this question and answer here for future reference of anyone facing this issue.