Grdview -T

gmt grdview $tmp/tmp2.grd -K -O -R -JX -T+o0.5p,255+s -Cbackdrop.cpt

is supposed to outline each tile. In GMT4.5 it did (the -T option without “+”). In
GMT6.0.0 it seems to outline the boundary to NaN’s and -R[region] of the combined set.
gmt grd2xyz ... | awk '! /NaN/{print $0}' | gmt psxy ... -SS
directly after produces what I want—with assistance from a previous gmt grdinfo to get the scaling right. The former elegance is gone. I tried a lot of variations of the -T option’s arguments to no avail. Any suggestions?

Don’t have an answer, but you need to update your gmt version; 6.4.0 is the latest. 6.0.0 is over three years old.

Can you provide an short full working example (MWE) that shows the problem?

We recently fixed some bugs and missing features in grdview -T if I recall (right @Andreas?) so possibly 6.4 will have the same trouble (but master is fixed).


It’s in the left diagram, the blue tiles, aiming to show a thin seam around.
gmt grdcut /home/loading/tide-models/netCDF/FES2004/amp.m2 -R$mapr -G$tmp/tmp.grd
gmt grdmath $tmp/tmp.grd 900 LE 0 NAN = $tmp/mask.grd
gmt grdmath $tmp/mask.grd 1.0 MUL = $tmp/tmp2.grd

gmt psbasemap -R$r -JX4.5/4.5 -Ba0.5f0.05/a0.25f0.05WeSN -K >! $tmp/olmpp$

Working result GMT4.5:
grdview $tmp/tmp2.grd -K -O -R -JX -Tso0.03,255 -Cbackdrop.cpt >> $tmp/olmpp$

Problem result GMT6.0.0.:
gmt grdview $tmp/tmp2.grd -K -O -R -JX -T+o0.5p,255+s -Cbackdrop.cpt >> $tmp/olmpp$

This is not a reproducible example

Okay. Here’s what you need. See READ.ME before you extract the rest

Maybe @Andreas could have a check since he helped us fix issues in -T as well as porting it to grdimage?

@Kompass17: Is the problem that you want the thin gray-ish outline of the cells?

I’m not sure I can help you, but if you want me to have a look you need to

  • upgrade to latest gmt (6.4.0) and check the result.
  • create a minimal working example. The link to the grid you posted does not work for me. I need a script that I can copy/paste and run.

Yes, the thin actually white grouting between the tiles is what I want. GMT6.4 is installed now, will test it any time later today. Thanks so long

1 Like

With v6.4 the problem is solved. Thanks for your help.