How to plot map with (mesh+surface) but with clear display

I am trying to plot an area map with (mesh+surface) features. I used the following way for plotting;

gmt begin
gmt figure Area_surface-mesh-map png
# plot surface map
gmt grdview example_relief.grd -R134/140/25/33/-6500/1000 -JM10c -JZ2c -p250/25 -Ctopo -I -N-6500+glightgray -Qs -Wf0.5 -BwEnSZ+b -Bzaf 
# plot surface+mesh plot
gmt grdview example_relief.grd -R134/140/25/33/-6500/1000 -JM10c -JZ2c -p250/25 -Ctopo -I -N-6500+glightgray -Qsm -Wf0.5 -BnwSEZ+b -Bzaf -Y-7
gmt end


In plotted Figure (top) map shows surface plot while in (bottom) map both surface+mesh are plotted. But mesh addition hide the surface features in plot and display is not visible.

Query is that whether it is possible to get clear display of plot (may be by reducing density of mesh), so surface features become more visible in Figure.

Below is a reference figure, in which mesh is added but surface features are more visible.

I’m afraid that’s not possible (harder than it might seem on first though since it’s not just a decimation operation). The solution will have to be to resample the grid onto a coarser one and use it to do the mesh plot layer.

But you can try -Wmfaint,gray@50 and see what it gives.

Idea (not tested, don’t even know if it’s doable at all):

Use grdcontour to manipulate the grid (coarser approach in a sense), then mesh the result

Thanks for your help. I tried with

the output figure with (surface+mesh) get some clear display.

I think it means to sample area grid from main grid data using grdcut at coarser rate. Previously I used grdcut in the way (gmt grdcut @earth_relief_01m -R134/140/25/33 -Gexample_relief.grd). Can you explain how to to grid area at coarser rate, which parameter can do this task?

Thanks for idea, I tried in following way;

gmt begin
gmt figure Area_surface-mesh-map png
gmt grdcut @earth_relief_01m -R134/140/25/33 -Gexample_relief.grd
# use grdview  
gmt grdview example_relief.grd -R134/140/25/33/-6500/1000 -JM10c -JZ2c -p250/25 -Ctopo -I -N-6500+glightgray -Qs  -BwEnSZ+b -Bzaf
# use grdcontour
gmt grdcontour example_relief.grd -JM10c -R134/140/25/33  -JZ2c -p250/25 -C400 -W2p 
gmt end


Using this way, contours are not appear in their correct positon on map. Do you have idea how to place contour to their correct position and then try your approach?

Just out of curiosity – why do you want the mesh displayed?