HSV colour model not recognised?

I’m desperate getting colours right using the HSV model.
I’m on GMT 5.2.1.
Looks like the H, S and V values are read as if they would be RGB.
For instance, 150-1-1 appears red (in a psxy command with -W1,150-1-1), when it should plot a green line with a 1pt width, at least if I understand correctly this model. I’ve tried all sorts of things and basically the colour does not change.
Any help welcome!

There is no way for us to confirm this, as 5.2.1 is ancient. I just tested things like

echo 0 0 | gmt plot -R-3/3/-3/3 -Jx2i -Sc1i -G150-1-1 -pdf t

and it is coming out green. I suggest you upgrade to a more recent GMT versino.

Thanks Paul.
The mystery actually thickens because, I have now installed GMT6.1.1 on my iMac (I just downloaded the dmg install file from the GMT website), and when I run the gmt plot command that you’ve just sent, I get a big red circle!
(and before running your example command, I set the HSV model and parameters).
And, I promise, I’m not colour blind! Cannot believe either that there is something special for us in the southern hemisphere!
Am I the first one reporting something like this?

here I get green:

echo 0 0 | gmt plot -R-3/3/-3/3 -Jx2i -Sc1i -G150-1-1 -pdf t --PS_COLOR_MODEL=RGB

but here I get red:

echo 0 0 | gmt plot -R-3/3/-3/3 -Jx2i -Sc1i -G150-1-1 -pdf t --PS_COLOR_MODEL=HSV

Thanks. I guess I never use the COLOR_MODEL settings since tehre is never any need, but cleary there are unintended (or perhaps intended) side-effects here. These are very old options harking back to the days when CTP files had individual columns for each color element, so it was not possible to tell RGB from HSV without relying on a flag. Now, all CPTs have strings, such as 150-1-1 so there is no confusion, but a few CPTs do have COLOR_MODEL = hsv in them, although I am not sure what that really adds.
I will create an issue to sort this out, but in the meantime just stop dealing with COLOR_* settings.

And whadduyaknow, there was an ancient bug in the PSL library that wrote hsv to the PostScript using h in 0-360 range (angle) but for PS it should be 0-1. That is why you got red. This is now fixed via this pull request. Moral is to lay off the use of PS_COLOR_MODEL as I cannot see any possible uses for it.

So thanks guys for pointing this one out!

Thanks Paul and others.
Indeed, just removing all the gmtset commands related to the colour model etc. solves the issue.
Green is green now!