Issue with the grid @earth_relief_03s

Hello everyone,

I am trying to plot a map for a small region. Therefore, I include the grid @earth_relief_03s. I set my -R such that it is a multiple of 3 arc seconds. However, my map does not have a good resolution and when I run my script I get this warning:
grdblend [WARNING]: File has different increments (0.00416666666667/0.00416666666667) than the output grid (0.000833333333333/0.000833333333333) - must resample
grdblend [WARNING]: File @N30E130**.earth_relief_15s** coordinates are phase-shifted w.r.t. the output grid - must resample
Why do I get a warning related to the grid earth_relief_15s when I defined the grid @earth_relief_03s?

This is my script:

gmt begin Sakurajima-image png
gmt basemap -R130:28:15/130:51:57/31:27:15/31:47:12 -JM18c -Baf -B+t"Probe" -V
gmt grdimage @earth_relief_03s -I+d
gmt colorbar -DjTC+h+o-0c/19.5c+w8c/0.5c+ml -Ba500+l"Earth relief [m]"
gmt coast -Slightblue -L+w5k+c10N+ab+o4c/1c+u --MAP_SCALE_HEIGHT=8p
gmt inset begin -DjTL+w3c+o0.3c #-F+gwhite+pthin
gmt coast -Rg -JG130.4696/31.7816/3c -Bg -Gwheat -SLightBlue -EJP+gdarkgreen
echo 130.5012 31.394 > frame.gmt
echo 130.8787 31.394 >> frame.gmt
echo 130.8787 31.8763 >> frame.gmt
echo 130.5012 31.8763 >> frame.gmt
echo 130.5012 31.394 >> frame.gmt
gmt plot frame.gmt -W5p,red
gmt inset end
gmt end show

I would appreciate your help!

Very likely because your region includes some marine part and the 03s, which are derived from SRTM data, only cover continental areas.

Thanks Joaquim for answering. Indeed! My region includes marine part. I tried with the grid @srtm_relief_01s and it looks good! The only problem is the “conflict” at the line of coast:

Here without -SLightBlue in the command gmt coast […]:

Could you please tell me how can I change this blue color? How can I assign a different color for the sea region? Which parameter is it?

Thanks in advance!
Best regards!

-SLightBlue fills the “sea” region in “lightblue”
-S255/0/0 would fill it in red (RGB format)
-S#ffffff would fill it in white (hex format)

GMT support different color formats :slight_smile:

If you aim to change the background directly (from grdimage layer)

I’m not 100%, but this might help : doc / color-parameters

gmt set COLORxxx (for everything)


grdimage [...] --COLORxxx (for this layer only)