Kernel died restarting, segmentation fault: 11, PyGMT-Anaconda-JupyterLab, Mac

Dear PyGMT team,

First, thanks so much for all the effort to make the GMT tools available via Python. I have been gradually shifting to it. A few days ago, my Jupyter-Lab/Anaconda started NOT working at all with a script that was running fine until a day before. It gives the following error message.

If I run in Terminal:
(pygmt) computer-MBP-3:~ mtominaga$ python
Python 3.9.7 | packaged by conda-forge | (default, Sep 29 2021, 20:33:18)
[Clang 11.1.0 ] on darwin
Type “help”, “copyright”, “credits” or “license” for more information.

import pygmt
Segmentation fault: 11

So I have tried from scratch again -
*completely uninstalled Anaconda (rm -rf)
*uninstalled pygmt, jupyter,
then installed Anaconda again followed by:
**conda config --prepend channels conda-forge
**conda create --name pygmt python=3.9 numpy pandas xarray netcdf4 packaging gmt
**conda activate pygmt
**conda install pygmt
**[if you are paranoic] conda update pygmt

The results were the same - kernel died (; segmentation fault:11.

Also tried:
(pygmt) Computer-MBP-3:~ mtominaga$ python -m ipykernel install --user --name pygmt
Installed kernelspec pygmt in /Users/mtominaga/Library/Jupyter/kernels/pygmt

with the following check:

Could you please share with me what can I do to run the PyGMT again with jupyterlab…I depleted options from both my knowledge and search.

Thanks so much for your help!

An update:
I tried and installed PyGMT via Anaconda (clean install) on another mac machine (followed the PyGMT installation page) - which yielded the exact same kernel error message.

Could you try installing jupyter lab inside the conda environment? These steps work for me on macOS 12.0.1 to use PyGMT with jupyter lab:

conda config --prepend channels conda-forge
conda create --name pygmt python=3.9 numpy pandas xarray netcdf4 packaging gmt
conda activate pygmt
conda install pygmt
conda install jupyterlab