Maximum size file uploads

I’m trying to upload a gif (animation) which is 1.4M (according to my os), but getting an error from the forum that says

Sorry, that file is too big (maximum size is 4096kb).
Why not upload your large file to a cloud sharing service,
then paste the link?

1.4M < 4096kb?

Not a huge issue, but thought I’d mention it.

I just checked the settings. $Mb on image and file uploads attachment. However, there is a 1Mb limit on “secure media files via email upload” so it would seem you are triggering that somehow?

Strange. I just dragged the file (.gif as mentioned) and dropped it in my ‘post-in-writing field’. No email upload involved as far a I know(…).