Mispositioned Colorbars in Subplots

Dear friends,
Please help me figure out the cause of the misplaced colorbars in the image below. I was expecting each colorbar to be positioned below its subplot; however, they are placed on top of each other at a weird position. I can use the offset feature in -D of colorbar to fix it, but I need to understand why this is happening; because the actual plot is a 3x3 subplot. Can someone kindly explain to me what I may be missing? I have ran it both GMT6.3.0 and 6.4.0, and the result is the same.

Below is the accompanying script.
UUUU.nc can be ETOPO1, GEBCO or any bathymetric grid around Hawaii.
Thanks very much.

gmt begin Jotter png
	gmt subplot begin 2x1 -A"(a)"+jTL+gwhite+o0.15i/0.07i -Fs6.2i/3i -M0.25i/0.4i -R-165/-150/15/30 -JQ6i
	    gmt subplot set 0 				
			gmt grd2cpt -Z UUUU.nc -L-10000/0 -Cturbo
			gmt grdimage UUUU.nc -I+d 
			gmt coast -Gpeachpuff4 -Df -Wthinnest 			
			gmt colorbar -DJBC -Bx2000 -By+lm
		gmt subplot set 1 				
			gmt grd2cpt -Z UUUU.nc -L-10000/0 -Cpolar
			gmt grdimage UUUU.nc -I+d 
			gmt coast -Gpeachpuff4 -Df -Wthinnest 
			gmt colorbar -DJBC -Bx2000 -By+lm		
	gmt subplot end	
gmt end show 

Cannot reproduce it but also using 6.5 master. Must be an old bug then.

Dear @pwessel, I am writing to inform you that my problem has nothing to do with the GMT version. I have installed 6.5.0, but the problem is not resolved. The issue affects my current computer; because I ran the script in 6.1.0 on an different computer and everything was fine. My instincts says I have done something wrong somewhere to the GMT settings. This is because I once tampered with the gmt.conf file some time ago last year; and since then, colorbar is always mispositioned on my computer.

Please do you have any idea what may be the solution? Sorry to disturb you. Many thanks to you and your team for this wonderful software.

I also can’t reproduce your issue with GMT 6.5.0.

Here are my suggestions:

  1. Use GMT 6.5.0
  2. Use gmt begin Jotter png -C so that the script won’t use any existing gmt.conf file
  3. If gmt begin -C doesn’t help, then please add gmt set GMT_VERBOSE debug after the gmt begin command and post the long debugging message to the forum so that we can see what’s happening

Hello @seisman,
Thank you for the help; however, gmt begin Jotter png -C did not resolve it. So, I have uploaded the debugging message.
GMT_Debug_Result.txt (152.2 KB)