Not working -A option to offset focal mechanism with Coupe GMT 6.3


I’m trying to offset some focal mechanism in vertical cross-section using -A option with coupe in GMT 6.3 using the following line:

gmt coupe Data.txt -Sm0.25c -Aa-73.2/6.817/-72.95/6.817+d90+w500+z-15/210+r -C -Q -JX14c/-10c -Bxaf+l"Distance (km)" -Byaf+l"Depth (km)" -BWSen -A -W0.25p

but that gives me the following error,

coupe [ERROR]: -A requires 4 arguments before modifiers.
coupe [ERROR]: Option -A: Unrecognized mode
coupe [ERROR]: Option -A: Given more than once (offending option is -Aa-73.2/6.817/-72.95/6.817+d90+w500+z-15/210+r)
coupe [ERROR]: Option -A: Unrecognized mode colorbar [ERROR]: Option -Dj requires the -R option

If I don’t put the last -A in Coupe line, It doesn’t give me any error. Any idea that what would be the problem?. I appreciate a lot your help

PD: I attach the data file, commands used to create and the figure created.

Commands used:

gmt begin
gmt figure test2 ps
gmt makecpt -T0/200 -Chot -I -N
gmt coupe Data.txt -Sm0.25c -Aa-73.2/6.817/-72.95/6.817+d90+w500+z-15/210+r -C -Q -JX14c/-10c -Bxaf+l"Distance (km)" -Byaf+l"Depth (km)" -BWSen -A -W0.25p
gmt colorbar -DjBR+o-2c/0c+w-10c+ml -Np -Ba100+l"Focal depth (km)"
gmt end show

Data.txt (1.2 KB) (52.6 KB)

I don’t understand why you are giving -A twice: Once with proper argument and a second time with no arguments. It is the second -A that causes all the troubles.

Unrelated, I am curious why you are using PostScript as the output - I thought nobody actually wants a pure PostSCript anymore which is why we switched to PDF.

I put double -A because I was thinking that it would works similar to meca which you add -A to activate the option to offset the focal mechanism. I eliminate the last -A and the errors disappear but I’m not still getting the results that I expect. The mechanism are still plotted in the same position (I attach the figure generated below).

test2.pdf (14.8 KB)

My idea is the mechanism looks displaced from his hypocenter position such as this figure shows:

The Data.txt file has the same columns required in -Sm option. Any ideas that what would be happen?

PD1: Lines used

gmt figure test2 pdf
gmt makecpt -T0/200 -Chot -I -N
gmt coupe Data.txt -Sm0.3c -Aa-73.2/6.817/-72.95/6.817+d90+w500+z-15/210+r -C -Q -JX14c/-10c -Bxaf+l"Distance (km)" -Byaf+l"Depth (km)" -BWSen -W0.25p
gmt colorbar -DjBR+o-2c/0c+w-10c+ml -Np -Ba100+l"Focal depth (km)"
gmt end show

PD2: I used Postscript as the output because some old codes return the outputs in PostScript so I prefer to have the figures in the same folders with the same formats. But as you said it’s better to have it in PDF.