Psconvert does not render transparency

I recently upgraded to Ghostscript 10 and GMT6.4 and now I cannot see transparency in jpg plot converted with psconvert.

I use a old syntax of gmt in a csh script.

From the output of psconvert with -V seems all in order, but I cannot see the transparent symbols in the jpg.

I use a MacBook Pro with BigSur 11.6.1

Thank you in advance for your help.

I have not tried gs 10.0.0 since the latest I see on mac ports is 9.56.1 but from past history gs has a way of screwing up transparency every few releases. We will need to see if we can reproduce it.

I was strongly suspecting of that as the GMT.jl documentation lost the transparency in all examples that use it. Very annoying this frequency at which gs fscrews.

Will be there any attempt to fix this or any tip on how to fix myself?

Thank you in advance!

Simplest “fix” is to move back to gs 9.56.1. @Joaquim, we need a tiny example that fails with 10 but works with 9.56.1 if we are to post on the gs bugzilla site.

I’m using a MacBook Pro with Monterey 12.0.1 and I’m facing the same issues.
How do I downgrade from gs10 to gs9.56.1? Is there any brew formula for that?

I am sure there is a standard way. I am using mac ports so cannot help. Maybe @seisman knows?

If you’re a Homebrew user, you can:

  1. Download the formula for ghostscript v9.56.1 ( to your computer
  2. Uninstall you ghostscript v10.00.0 by running brew uninstall ghostscript
  3. change into the directory where you downloaded the old formula ghostscript.rb, and run brew install ./ghostscript.rb. brew will use the formula in the current directory by default.

I have the same problem, thanks for the tip… I followed the procedure but in my case Homebrew always fetches the *.rb formula of the 10.00.0 version

thank you for helping

Sorry. The last step should be brew install ./ghostscript.rb instead. I’ve revised my answer above.

I should have thought myself…sorry…It totally worked and transparency are back.
Thank you very much!

I apply this method but brew still upgrades it to gs10. I found out that while uninstalling gs10, gs9.56.1 was still in the root. I did brew doctor and even brew link, but getting this message “psconvert [ERROR]: Cannot execute Ghostscript (gs)”.
How could I fix that issue?

What happens if you just type gs in your terminal? Or type which gs to see its full path.

I’ve fixed it by uninstalling the existing gs9.56.1 and running later on brew install ./ghostscript.rb.
It works now. Thank you!

Turns out this was actually a GMT problem (we did not check for gs version numbers > 9). A PR has been merged into master that fixes the problem on our side and now gs 10 works fine with GMT master.