PyGMT v0.1.0 released!

:tada: It is with great pleasure that we announce the first official release of PyGMT v0.1.0! :tada:

PyGMT is a Python interface for the Generic Mapping Tools. This release marks the result of months if not years of work from @leouieda, @seisman and the rest of the PyGMT team. Here are a few highlights from this release:

  • Python 3.8 is now supported (#398)
  • PyGMT now uses the stable version of GMT 6.0.0 by default (#363)
  • Use sphinx-gallery to manage examples and tutorials (#268)

The full list of changes can be found in the changelog, including a list of all contributors. Installation instructions can be found at https://www.pygmt.org/v0.1.0/install.html. We’re happy to say that not only is the pygmt package on PyPI, but also conda-forge too (Linux/MacOS only)!

Disclaimer: The package package is still undergoing rapid development, and the API is subject to change in future releases. We are particularly aware that Windows users will encounter installation issues, and are working on it at https://github.com/GenericMappingTools/pygmt/pull/313.


Roadmap to v0.2.0

Looking into the future, here are some new features being planned:

  • Support Windows properly (#313)
  • Implement subplot wrapper (#412)
  • Documentation fixes (e.g. #79)
  • etc

As always, we’re open to feedback and contributions, especially from new users! Feel free to ask us questions here on the forum, or submit bug reports on our Github issue tracker.

Enjoy :partying_face:

6 Likes

Thank you @weiji14 for handling the release! Much appreciated :confetti_ball:

Dear
I am installing the pygmt on the WINDOW-10.but it is showing the following error

File “C:\Users\vmt\AppData\Local\Programs\Python\Python38\lib\site-packages\pygmt_init_.py”, line 30, in
_begin()
File “C:\Users\vmt\AppData\Local\Programs\Python\Python38\lib\site-packages\pygmt\session_management.py”, line 16, in begin
with Session() as lib:
File “C:\Users\vmt\AppData\Local\Programs\Python\Python38\lib\site-packages\pygmt\clib\session.py”, line 177, in enter
self.create(“pygmt-session”)
File “C:\Users\vmt\AppData\Local\Programs\Python\Python38\lib\site-packages\pygmt\clib\session.py”, line 325, in create
c_create_session = self.get_libgmt_func(
File “C:\Users\vmt\AppData\Local\Programs\Python\Python38\lib\site-packages\pygmt\clib\session.py”, line 276, in get_libgmt_func
self._libgmt = load_libgmt()
File “C:\Users\vmt\AppData\Local\Programs\Python\Python38\lib\site-packages\pygmt\clib\loading.py”, line 42, in load_libgmt
libgmt = ctypes.CDLL(os.path.join(libpath, libname))
NameError: name ‘libname’ is not defined

Kindly help me to install the Pygmt in my computer system

Thank you very much

with regards
Radheshyam

Congratulations to @leouieda and @weiji14 for getting the first official release out the door! Many thanks for your hard work!

@shamgpbhu, you’ll have to install GMT (go to https://www.generic-mapping-tools.org/download) for pygmt to work (pygmt is not a standalone program). Also just be aware that Windows is not fully supported yet, see https://github.com/GenericMappingTools/pygmt/pull/313.

@weiji14, Thank you very much reply, I have ready installed the window-gmt.

but I am unable to solve my problem.It is showing the same error.

thank you very much

with regards
Radheshyam

I don’t understand those problems on Windows. I just did (again)

pip install pygmt

(had to also install pytest, which is not mentioned in the docs) and it fails, but clearly for another reason, since the gmt_w64.dll was correctly found.

>>> pygmt.test()
Loaded libgmt:
  binary dir: C:/programs/WPy64-3.7.2/python-3.7.2.amd64
  cores: 12
  grid layout: rows
  library path: C:/programs/GMTdir/gmt_w64.dll
  padding: 2
  plugin dir: C:/programs/GMTdir/gmt_plugins
  share dir: C:/progs_cygw/GMTdev/gmt5/compileds/gmt6/VC14_64/share
  version: 6.1.0
ERROR: usage:  [options] [file_or_dir] [file_or_dir] [...]
: error: unrecognized arguments: --mpl
  inifile: None
  rootdir: C:\Users\joaqu

Are you sure you didn’t ignore a message during GMT installation saying that it could not update your path?

ERROR: usage: [options] [file_or_dir] [file_or_dir] [...] : error: unrecognized arguments: --mpl

The error message is simply because you didn’t install the pytest-mpl package for image comparison.

File “C:\Users\vmt\AppData\Local\Programs\Python\Python38\lib\site-packages\pygmt\clib\loading.py”, line 42, in load_libgmt
libgmt = ctypes.CDLL(os.path.join(libpath, libname))
NameError: name ‘libname’ is not defined

@shamgpbhu I’m afraid you’re not installing the correct pygmt version.
For PyGMT v0.1.0, line 42 of the pygmt/clib/loading.py is

libgmt = ctypes.CDLL(libpath)

thank you for reply, but from we get correct version