X2sis_put ERROR?

I encounter an unclear error message when I use the x2sys_put command.

First I created, sucssefully, a tbf file containing the indexes for the data tracks.
This is through:
gmt x2sys_binlist *.mgd77 -TMGD77 -D -V > Ifermer_all.tbf

After that, in order to add the data tracks to the data base, I used the command:
gmt x2sys_put Ifremer_all.tbf -F -V -TMGD77

For that I get the following error message:
ERROR: Caught signal number 11 (Segmentation fault: 11) at
0 libgmt.6.dylib 0x0000000109d7170d gmt_fgets + 29
1 ??? 0x00007ffee5efd0be 0x0 + 140732756119742
Stack backtrace:
0 libgmt.6.dylib 0x0000000109d138e7 sig_handler + 555
1 libsystem_platform.dylib 0x00007fff77315b5d _sigtramp + 29
2 ??? 0x0000000110b08b76 0x0 + 4574972790
3 supplements.so 0x000000013208933f GMT_x2sys_put + 1072
4 libgmt.6.dylib 0x0000000109d31f05 GMT_Call_Module + 1890
5 gmt 0x0000000109d075a5 main + 1426
6 libdyld.dylib 0x00007fff7712a3d5 start + 1
7 ??? 0x0000000000000006 0x0 + 6
What does it mean and how should I resolve it?
I use gmt 6.2. Should I update the version?

Thank you all.

Better representation of the error massage

That is a definitively big YES. The problem may or may not have been solved meanwhile but only last version can tell that.

Thank you @Joaquim.
I’m not sure why, but it seems that the problem was with the GMT 2.0 program I’ve installed through Homebrew. once I replaced it with the one I downloaded from the application bundle - problem solved.