Xyz2grd - no output (and no error messages)

Not sure what I’m doing wrong.

xyz2grd z_file.txt -Gout.grd -I0.1

doesn’t complain but produces no output grid file.

Tried different input files, redirecting file ("<") instead of just naming it.
Also tried a Z-file with -Rrange and -XTLf

Even something like:
xyz2grid -I0.1
No error message. Nothing!

The only time I get a response (help message) is if I leave off all parameters.
Vers: 5.4.3 (r19528)

What’s your GMT version?

The command below works well for me:

gmt xyz2grd -I1 -R0/3/0/3 << EOF
1 1 1
1 1 2
2 1 1
2 2 2

Yep, that worked.
Eventually got my commands to work. I think it was an issue with the spacing specified with -I not matching that of the data - especially with the -Z file - but couldn’t reproduce the problem for the text input.
Weird that nothing was output but no error messages were given.

GMT5.4 is an old version. This is what I get with GMT6

xyz2grd -I0.1
xyz2grd [ERROR]: Must specify -R option
xyz2grd [ERROR]: Option -G: Must specify output file