PS_CHAR_ENCODING works selectively?

I want to use additional fonts (and encoding) from GMT example #31 in such cases as
pscoast (-B+t"…“), (psscale -Bx+l”…") but the alternate encoding works in pslegend or pstext in case of explicit indication of font name

chcp 28595 >nul
gmtset FONT LinBiolinumO FONT_TITLE 16p,LinLibertineOB
set /p ss=<europe-capitals-ru.csv
echo %ss%
::read 1st string and echo it
set pp=2,%ss%
for /f “tokens=4 delims=,” %%i in (“%pp%”) do @set сity=%%i
::parse first string (3rd element, Amsterdam)
pscoast -Dl -R-10/50/64/66/r -JL15/50/40/60/16c -P -Bx10g10 -By5g5 -B+t"Европа %сity%" -A1500 -Slightblue -Glightgreen -W0.25p -N1/1p,white -K >
::try to plot using ISO-8859-5 (cyrillic) text from file and directly from code
for /f “tokens=1-3 delims=,” %%i in (europe-capitals-ru.csv) do @echo %%i %%j %%k |pstext -R -J -F+f7p,LinBiolinumOI+jBL -Dj0.1c -Gwhite -C5%% -Qu -TO -O -K >>
pslegend -R -J -DjTR+o0.1c+w8.0c+l1.2 -C0.3c/0.4c -F+p+gwhite -O legend_ru.txt >>

changing font number @%%36%% does not feel the given encoding
setting --PS_CHAR_ENCODING=ISO-8859-5 as an argument does not works too

Please, tell me how to make it work in this cases
GMT 5.4.5 on Windows 7
gs_fontpath assigned (1.5 KB)