Ubuntu updated to 20.04.3 netcdf libraries seem broken

As the post said, I updated to Ubuntu 20.40 when I run GMT4 (or even GMT5 for that matter) I get the following:

psxy: error while loading shared libraries: libnetcdf.so.13: cannot open shared object file: No such file or directory
I have tried to reinstall GMT4 from source and redownload

Found this discussion and one solution proposed near the bottom didn’t seem to work.
http://gmt.soest.hawaii.edu/boards/1/topics/7578

Any suggestions?

I get such message from time to time after the OS has updated basic libraries (like netCDF) and my own build of GMT happened before then, thus pointing to the old now gone version. Wipe the GMT build and build again usually fixes this.

Here it is working, but it is linked to libnetcdf.so.15:
$ cat /etc/issue.net
Ubuntu 20.04.3 LTS
$ ldd /usr/local/GMT4.5.18/bin/psxy | grep netcdf
libnetcdf.so.15 => /lib/x86_64-linux-gnu/libnetcdf.so.15 (0x00007f42d52c5000)
Not sure if it could help, but I’m including the GMT4param.txt that I’ve been using for a long time.
GMT4param.txt (2.5 KB)
And if you have installed gmt using apt-get. I suggest you to purge that installation.